Author Topic: DooC-Menü – Exit mit ET:Legacy  (Read 1165 times)

Kissaki

  • Leader
  • Forum God
  • *****
  • Posts: 10.306
    • View Profile
    • Website
DooC-Menü – Exit mit ET:Legacy
« on: 02.02.2013, 19:54:49 »
Wenn ich ET:Legacy mit Exit beende öffnet sich nach dem Beenden im Browser folgende URL
Code: [Select]
http://et.trackbase.net/index.php?mod=claninfo&cidx=213%20;%20set%20cl_noprint%201;exec%20dooc_menu_website_address.cfg;set%20cl_noprint%200%20;Keine Webseite.
Und das ET minimiert sich nur.

Das heißt wer die Konsole nicht kennt oder zu bedienen weiß, der bekommt sein ET nicht mehr beendet.


Ich fänds außerdem gut wenn man wenigstens wählen könnte ob man die trackbase Webseite öffnen möchte nach dem Beenden oder nicht. Die Wahl hat man ja momentan nicht …

ヤン

Kissaki

  • Leader
  • Forum God
  • *****
  • Posts: 10.306
    • View Profile
    • Website
Re: DooC-Menü – Exit mit ET:Legacy
« Reply #1 on: 03.02.2013, 12:44:07 »
Analysis:
The button `Exit Game` is defined in `~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~z_dooc_menu.pk3`,
`ui/ingame_main.menu` line 50,
with the action
Code: [Select]
clearFocus ; exec "set ui_finalURL http://et.trackbase.net/index.php?mod=claninfo&cidx=213" ; open dooc_website_confirm
`dooc_website_confirm` is defined in `ui/dooc_website_confirm.menu`
with the action
Code: [Select]
close dooc_website_confirm ; uiScript validate_openURL
The main menu (not ingame) on quit for Yes defines in `ui/quit.menu`
Code: [Select]
close quit ; close main ; open credits_quit

`ui/dooc_website_confirm.menu`
has a
Code: [Select]
exec "set cl_noprint 1;exec dooc_menu_website_address.cfg;set cl_noprint 0"
dooc_menu_website_address.cfg contains
Code: [Select]
set ui_finalURL "http://www.dooc-clan.de"


So the first thing I notice is:
It currently has code for seemingly trying to open two websites, which does not work. Opening the dooc website is overwritten by opening the trackbase website.
I thus first suggest removing the onOpen and cfg.

I attached a prepared, updated pk3. Removed the two now unnecessary dooc_menu_website_address.cfg files, and updated the ui/dooc_website_confirm.menu onOpen to not include the exec .cfg.

I also suggest introducing version numbers into the filename.
« Last Edit: 03.02.2013, 12:59:35 by Kissaki »

ヤン

Gauki

  • CoLeader
  • Forum God
  • *****
  • Posts: 2.096
    • View Profile
Re: DooC-Menü – Exit mit ET:Legacy
« Reply #2 on: 03.02.2013, 20:15:36 »
i will talk next time if i have time with you in mumble!

First reasons why i want this exit: 1. everyone see all infos about us (dooc) 2. i want to catch the different countries (geoip) 3. i want to give tb backup :)

and i think the webside are correctly set.. one is to open the dooc page if u open esc [DooC] dooc-clan.de and the other start only if u disconnect ;) so all fine ? (without the litte prob of et legacy) ... lets see if there is a solution ^^


Kissaki

  • Leader
  • Forum God
  • *****
  • Posts: 10.306
    • View Profile
    • Website
Re: DooC-Menü – Exit mit ET:Legacy
« Reply #3 on: 10.05.2013, 00:15:04 »
I fixed the image in main menu,
and the ingame menus exit button (now exits in ET:L and others as well, and uses correct url to open),
and the ingame dooc menus website link (now exits in ET:L and others as well, and uses correct url to open).
And the main menu buttons for server 2.60 and 2.55 pointed to the same server and port. They now point to the appropriate ports.

The ultra shitty file name gives me joy as always.
The tildes (~) are ordered *after* other characters. So I was right when I initially said the content is loaded first to last, with the last being effective. Windows orders the ~ in front, but ET in the back.
I don’t remember the max filenamelength you Gauki told me; I hope its still ok. I already uploaded it to the server and introduced a version number, so we can actually update it in the future.

Oh the joy of the menu files … :-/


There is still an issue with the set finalURL that is opened. After setting via exec set it appends a space and semicolon to the url / value. Do not know why. Have no solution.

Another issue is that in the main menu the server buttons both light up when hovering over one. Not sure what is executed when you click either of them.
« Last Edit: 12.05.2013, 18:15:21 by Kissaki »

ヤン